Wednesday, May 25, 2011

How To Fix RubyGems Deprecation Warnings

RubyGems issues deprecation warnings which can easily fill a whole screen. There's been debate about this move, but it's a waste of time debating it when the code is so easy to fix.

Go to the Ruby directory for whichever Ruby version(s) you wish to repair. Then edit the file lib/ruby/site_ruby/1.8/rubygems/deprecate.rb, line 61.