Wednesday, May 25, 2011

Rails 3.1 Release Candidate: Specific Gem Versions

rails: 3.1.0.rc1
rake: 0.8.7
sprockets: ~> 2.0.0.beta.5
rspec-rails: 2.6.1.beta1
mysql2 (and specify that as your adapter in config/database.yml)

rake db:test:prepare is now just rake test:prepare.

You may also need to hack RubyGems to make it usable. People have also recommended downgrading to 1.7.2 or 1.6.7.